Debian_Package_split
Last change
on this file since a84272 was a84272, checked in by Frederik Heber <heber@…>, 8 years ago |
tempcommit: Attempt at splitting molecuilder into multiple packages, does not work so far.
|
-
Property mode
set to
100755
|
File size:
909 bytes
|
Line | |
---|
1 | #!/usr/bin/make -f
|
---|
2 |
|
---|
3 | include /usr/share/cdbs/1/rules/debhelper.mk
|
---|
4 | include /usr/share/cdbs/1/class/autotools.mk
|
---|
5 |
|
---|
6 | DEB_CONFIGURE_EXTRA_FLAGS += --disable-debug --disable-valgrind --enable-qtgui-capture-log --enable-action-thread --enable-jobmarket --enable-vmg --with-vmg-mpi --enable-python --enable-qtgui --enable-qwt --enable-levmar CXX='mpic++' CC='mpicc' F77='mpif77' --with-Qt-bin=/usr/share/qt4/bin --with-qwt-include=/usr/include/qwt-qt4 --with-qwt-libdir=/usr/lib --enable-production
|
---|
7 |
|
---|
8 | DEB_MAKE_CHECK_TARGET = check
|
---|
9 |
|
---|
10 | DEB_DH_STRIP_ARGS := --dbg-package=molecuilder-dbg
|
---|
11 |
|
---|
12 | # this seems to fix issues with launching molecuilder_mpqc crashing with
|
---|
13 | # obscure OMPI errors,
|
---|
14 | # see https://lists.debian.org/debian-science/2012/03/msg00005.html
|
---|
15 | # In any case this works also before actually launching the executable.
|
---|
16 | export OMPI_MCA_plm_rsh_agent=/bin/false
|
---|
17 |
|
---|
18 | #include /usr/share/gnome-pkg-tools/1/rules/clean-la.mk
|
---|
Note:
See
TracBrowser
for help on using the repository browser.